Degraded Performance on device state endpoints

Incident Report for balena.io

Resolved

This incident has been resolved.
Posted Apr 18, 2025 - 12:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2025 - 15:00 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 17, 2025 - 14:56 UTC

Investigating

We are currently investigating this issue.
Posted Apr 17, 2025 - 14:38 UTC
This incident affected: API.